Transferz - Help center outage – Incident details

All systems operational

Help center outage

Resolved
Partial outage
Started 20 days agoLasted 24 minutes

Affected

Help center

Partial outage from 7:31 AM to 7:55 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified the issue and continuing to roll-out a fix for this issue.

  • Investigating
    Investigating

    Help center FAQ content is not loading. We are investigating the cause of the issue.